<a-C> with setxkbmap -option "grp:lalt_lshift_toggle"


#1

I had some issues with the <a-C> multiple selection command and the -option "grp:lalt_lshift_toggle from setxkbmap.

On another system, which I"m almost sure I have the same configuration setup from setxkbmap, I had no issues whatsoever.

Would someone be kind enough to test this for me. I did struggled for a while until I went ahead and changed the -option to toggle between the layouts.

Please note I was using the rightShift key for <a-C>

It does look to me like setxkbmap’s fault at this point.

Thank you in advance if someone could go out of his way to confirm it for me.


#2

On an another slightly unrelated note, on the system where ‘supposedly’ everything was running smooth, the <a-I> combination as it was implemented on the excellent Ability to split object selections plugin was simply not working.

Checked, rechecked, double checked, checked again, but nothing.

On rxvt-unicode mouse scrolling was sending characters back and forth to the screen! Well, not so much back from, but rather into the screen akin to planet earth getting bombarded by comets, meteorites in hit-and-miss ruthless fashion.

Anyhow, back to xterm, nothing worked. I gave up. <a-I> wasn’t doing anything.

I checked on the desktop environment looking for clues, But nothing yet. But then I checked again against my other configuration file and there ti was as I remember setting it up once xterm*metaSendsEscape set to true.

:slight_smile:

This downloadable link ftp://www.x.org/pub/X11R6.8.0/PDF/ctlseqs.pdf

confirms it with Don’t send ESC when Meta modifies a key (disables the
metaSendsEscape resource).

edit but what metaSendsEscape is going to disable, if it’s by default disabled. It was never enabled until after… and which in turn made the command a-I from the plugin to work on that system … sigh


#3

The question that lingers i(at least in these two cases) s the following

with -option grp:lalt_lshift_toggle the <a-C never worked. But then again, xterm*metaSendsEscape was never set (default is false)

with xterm*metaSendsEscape to true, <a-I> worked flawlessly on the system where -option grp:lalt_lshift_toggle was never set

Anyhow, I guess it would be the original question the -option grp:lalt_lshift_toggle that troubles me the most in which a-C never worked.