How to navigate in markdown files

How to configure kak-lsp to navigate in markdown ?
I tried with zk but not able to make it working with (zk lsp in other terminal is started):

filetypes = ["markdown"]
roots = [".zk"]
command = "zk"
args = ["lsp"]

I also tried with marksman with the same that is OK in helix :

name = "markdown"
scope = ""
injection-regex = "md|markdown"
file-types = ["md", "markdown"]
roots = [".marksman.toml"]
language-server = { command = "marksman", args=["server"] }
indent = { tab-width = 2, unit = "  " }

the zk config is correct but it looks like they don’t support go-to-definition for what I tried.
Here is a valid marksman config; gd works as expected on the links below.

[language_server.markdown] # NOTE for kak-lsp < 15.0.0 this would need to be `[language.markdown]`
filetypes = ["markdown"]
roots = [".marksman.toml"]
command = "marksman"
args = ["server"]
## AAA

## BBB

links to
- [AAA](#AAA)
- [BBB](#BBB)

I wonder which one is the right default. There’s also vscode-markdown-language-server

I could test it. It is working. Thanks.
Hope it can help another than me.

I saw that you can use helix+marksman as obsidian to manage markdown :
Helix & marksman! (why I don’t use Obsidian) - YouTube
Helix: Setup for Markdown. Helix is fantastic, there’s almost no… | by Bacchus Jackson (BJax) | Medium
But I want to see if I can with Kakoune

I could also configure the formatter with dprint in kakrc with :

hook global WinSetOption filetype=markdown %{
    set window formatcmd 'dprint fmt'

After you need to use the command :format