Kak-lsp and gopls not working

Getting this nonstop when i run kak-lsp -s 0:

Nov 20 10:57:45.493 ERRO Error response from server: Failure { jsonrpc: Some(V2), error: Error { code: ServerError(0), message: "no object found", data: None }, id: Num(10) }, module: kak_lsp::controller:127

Inside the editor it shows a go language server error: 'no object found'

I tried installing gopls from the distro package manager and manually using the lastest from the official repository.

I see you also posted this on reddit, but that sub is rather devoid of activity. If you didn’t catch anyone’s attention here, try the issues for the project. Good luck with this. I have had a frustrating time getting any of the LSP stuff to work reliably in any editor.

1 Like

Posted there. For python it’s working fine here.

Looking around a issue opened there in 2019, it seems that this is a problem with gopls. I’ll wait to see if there is anyone who could make it work, but i remember i had this the last time i tried, but it was probably with go-langserver.