Kakoune-mysticaltutor, a flat low-contrast colorscheme

Hi all, I finally put together a repo for a kakoune port of my not-super-popular colorscheme Mystical Tutor. It is available at https://github.com/caksoylar/kakoune-mysticaltutor.

Its main “innovation” is using alpha-blended colors for selections, thus syntax highlighting is still preserved inside selections, as in the above screenshot. I also made sure that all primary and secondary selections are distinct both for main selection content, cursors and cursors at end-of-line.

Thanks to @ftonneau for the compilation of themes in the “see also” section and @mawww for rgba colors and making it easy and intuitive to define colorschemes.

Edit: Added more terminal themes in the main repo for Windows Terminal (thanks @jordan-yee), Alacritty and Kitty.


This :heart_eyes:


Dang, this is really nice - lovely and calming while still being very readable.

1 Like

I put together a powerline theme to match, and was going to make a pull request to add it to your theme’s repo, but as far as I can tell that isn’t possible when using the theme keyword with plug.kak. Maybe @andreyorst could say otherwise.

Since I couldn’t get that to work, I put it in a new repo to be installed as a separate plugin:

Feel free to steal that and make an official version if you’d like.

At first I thought your colors might be bit flat for my taste, but after using it a few days your theme is growing on me, so I’ll be keeping it for a while at least. Thanks for putting it together!

Thanks for the nice words (and the other commenters too)! I had been using it for some time but I am happy that I released it since people seem to like it.

I think it’s fine to keep this a separate repo, I’ll put a pointer to it in the kakoune-mysticaltutor README. It looks good, thanks for your work!

PS. All your powerline.kak links actually go to plug.kak in the README.

PPS. I saw in your screenshot that the session name in status-left in the tmux statusline is brightred instead of red, since WT doesn’t support bold and tmux doesn’t seem to disambiguate bold and bright as WT understands it right now. You might want to change it to remove the bold, i.e.

set-option -g status-left '#[fg=red] @#{session_name} '

Thanks for catching the links–they’re fixed now.

I also changed the tmux colors according to your recommendation, and do like that better. Even though that’s not part of the powerline theme, I updated the screenshot there as well.

@bravekarma You can use variables, like in dracula.kak.

That’s a good idea! I didn’t like that most colorschemes shell out to use variables for something that is (mostly) write once and run many times, but using options shouldn’t introduce much overhead. It does pollute the options space, but using -hidden would help a bit.

Color scheme options are useful to access the color values from your kakrc.

It’s 4am and the colour scheme is holding up nicely on my tired eyes. Appreciate the work @bravekarma and thanks for going the extra mile @jordan-yee.