Alt-j text mode

hello guys:

I can’t get alt-j to join lines.

I can have alt-J to ~join~ select or whatever other terminology there exists to join lines and for selecting spaces is.

What gives?

So, right now, I’m pretty much stuck in having to use whatever other ui terminal there is, ahem ahem, ‘emulator’, that would allow me to join some lines through a simple alt-j for a menial task of joining lines,

Or else I have to settle and hit an extra key for just making the j uppercase… I mean, what is this?

And yes… after googling about this issue, I also came across and — not surprisingly, this has nothing to do with it.

I suspect your terminal doesn’t send alt properly. You didn’t give what terminal you are currently using, but a lot of terminals on OS-X do not handle alt properly without configuration.

@robertmeta hello Robert. No. It’s the virtual console. No emulator.

As a matter of fact, any emulator is fine. I haven’t tried st yet, but I’m almost sure it’ll behave just as good.

I just tried on Ubuntu 20.04 went to a naked raw term, worked fine. I don’t know what to say except it isn’t a problem here. I also haven’t seen it reported by others.

Can you install a fresh Arch and try it out? Other alt- combinations seemed to work fine, except joining lines.

Also, my kak is at (give me a sec to check it) 74e3e5ef

what terminal emulator are you using?

@andreyorst Hey Andrey, long time don’t see man. :slight_smile: Andrey, right now gnome-terminal. But the emulator is fine.

If memory serves me well here, you used to run Arch a while back. You can tryi it out.

Hm, it works for me in Gnome Terminal.

It was a long ago, I’m wearing fedora nowadays… But I have arch on my old pc, I’ll check if there are any differences.

Hahaha, no.

1 Like

Andrey, as I said: it works for me on gnome-terminal.

but then you’ll be able to came anywhere and say, btw, I use aI’ll show myself out…

@nonumeros, than perhaps I don’t understand the problem? Where it doesn’t work then?

Robert. It’s only like ~700MB give or take.

Andrey, if it doesn’t work then I wasn’t aware of it. That’s fine. :slight_smile: I guess I’ll have to use alt-J only and live happily ever after.

Have you tried a console keylog tool, xev, showkey, etc to confirm alt-j is being sent properly?

Robert, but aren’t those tools you mentioned, gui-oriented? Anyhow, I tried showkey and nothing seems off. Besides, it works with any emulator.

But ‘it is what it is’

Just tested in Arch linux virtual console and a-j works just fine for me. Might be something with keyboard layout or some other system configuration issue?

thanks for checking for me @cipharius… mmm, I’ll check again for any config issue as you suggested. It works elsewhere but there.

@cipharius @robertmeta dvorak qwerty work fine… not colemak :slight_smile:

this is funny after all ⸮ I’ll look into it later

@cipharius @robertmeta @andreyorst if you guys could loadkeys colemak and let me know from your end what you get so i can hopefully narrow it down here. I appreciate any help from you or anyone else with this.

You guys already know this but just for reference:

what is vitrual console? Do you mean tty?